Thread: Help me!!!
View Single Post
Old 04-07-2008, 11:51 AM   #1
A.M.G.
Dr. Chim Richalds
 
A.M.G.'s Avatar
 
Join Date: Sep 2007
Location: plane of pure scrumtrulesence
Posts: 3,595
A.M.G. has a terrific reputationA.M.G. has a terrific reputationA.M.G. has a terrific reputationA.M.G. has a terrific reputationA.M.G. has a terrific reputationA.M.G. has a terrific reputation
Default Help me!!!

I own Medieval 2. Play it, love it. So I bought the expansion, Kingdoms, and tried to install it. But for some reason you need Medieval 2 to be updated to version 2 or 3 or something, in order to be able to install the expansion. And I don't know how to update Medieval 2! I have tried to do it several times, but I am obviously doing something wrong, because the download fails everytime.

Can anybody tell me what I should do to update Medieval 2? Or direct me to a website that will tell me how to do it properly? I've kind of given up for a while, but seeing this thread reminded me.
A.M.G. is offline   Reply With Quote